Java StackOverflow Error after upgrade to XL Release 9.0

#1

Hi community!
After XL Release upgrade from 8.6 to 9.0 I have got that error:

Script failed. Exception during execution:
RuntimeError: maximum recursion depth exceeded (Java StackOverflowError) in at line number 10

It occurs in task: XL Deploy : Deploy

Can it be caused by requiring too many recursive calls before fulfilling condition?
What’s the way to fix it?

#2

Hello Jakub,

This could be a known issue. Please submit a support ticket here - https://support.xebialabs.com/hc/en-us/requests/new?ticket_form_id=30145 and include xl-release.log showing a task that gets this error.

Regards,
Adam

1 Like
#3

You are right- it was known issue.
Support Team supplied me with a fixed plugin file. Quick and painless, thanks!