XLDEPLOY 9.7.10 upgrade error

I’m upgrading XLDEPLOY 9.5 to 9.8.10 (LTS) version and receive error:

org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name ‘serviceHolder’ defined in URL [jar:file:/D:/xl-deploy-9.7.10-server/lib/xl-scheduler-9.7.10.jar!/com/xebialabs/xlplatform/scheduler/spring/ServiceHolder.class]: Unsatisfied dependency expressed through constructor parameter 1; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name ‘engine’ defined in com.xebialabs.deployit.spring.EngineBeanBuilder: Bean instantiation via factory method failed; nested exception is org.springframework.beans.BeanInstantiationException: Failed to instantiate [com.xebialabs.deployit.engine.tasker.TaskExecutionEngine]: Factory method ‘engine’ threw exception; nested exception is com.esotericsoftware.kryo.KryoException: java.lang.IndexOutOfBoundsException: Index: 82, Size: 82

XLDeploy server is not starting, any suggestions please?
Thank you in advance!

Can you post this in XL Deploy please?

I did it like this - https://meta.discourse.org/t/move-topic-to-other-category/160090

Hi n_nebojsa,

This sort of problem is probably best suited for technical support. Please submit a ticket here - https://support.digital.ai/hc/en-us

Regards,
Adam